
Kezelési útmutató az Origin 3.5 programhoz 
 

Indítsuk el a programot! Ekkor a program menüsora (File, Edit, Plot, Column, Data, 
Convert, Window) alatt még egy Data1 feliratú ablak (egy Worksheet) is található. 

Ha bármikor új ablakra van szükségünk, akkor a File > New menü alatt a megfelel� 
ablak (Plot Window, Worksheet) kiválasztásával nyithatunk. 

Az egyes menüpontok szisztematikus részletezése helyett az adatfeldolgozás során 
alkalmazandó sorrendet fogjuk követni. A továbbiakban a “Tippek és trükkök” fejezet 
megfelel� pontjaira szögletes zárójelbe tett számmal fogunk hivatkozni. 
  
MENTÉS 

Adataink bevitele után biztosan szeretnénk biztonságban (nem a gép memóriájában, 
hanem a HDD-n vagy hajlékonylemezen) tudni az origin file-t. Mentsük el a dokumentumun-
kat! Válasszuk ki a File > Save as… menüpontot és a párbeszédablakot értelemszer�en töltsük 
ki. File névként maximum 8 karaktert adjunk meg! File-jainkat ne az Origin könyvtárába, 
hanem a C:\Document könyvtárba mentsük! Amennyiben a Save menüpontot választjuk, 
akkor is elmenti a file-t a program, de az eredeti néven (ez Untitled.org). Ez nem tanácsos, 
ugyanis ha véletlenül egy számolás újra után szükség lenne a grafikonok módosítására vagy új 
illesztésekre, akkor ez esetben ne lep�djünk meg, ha egy másik hallgató másik mérésének 
értékelését tudjuk csak betölteni (tehát mindent elölr�l kell kezdeni). 

 
M�VELETEK AZ ADATLAPON (Worksheet) 
 
Adatok bevitele 

Az adatok feldolgozásához nélkülözhetetlen az adatok bevitele. Ennek két módja van: 
közvetlenül beírhatjuk, vagy file-ból olvastathatjuk be egy Worksheet-be. Az els� módszer 
alkalmazása néhány, a jegyz�könyvben szerepl� adat esetén, a második módszer használata 
számítógépes adatgy�jtéssel kapott, nagy mennyiség� adat feldolgozása esetén célszer�. Az 
adatok közvetlen bevitele esetén minden adat beírása után a fel vagy le nyilakkal vagy az 
ENTER billenty� lenyomásával fogadtassuk el az adatot a programmal. A file-ból olvasás a 
File menü Import pontja alól kiválasztott ASCII almenüvel végezhet� [1]. Célszer� a List 
Files of Type mez� módosítása *.dat-ról *.*-ra (így minden file látszani fog a könyvtárakban).  
 
Számítások 

Az esetek többségében a bevitt adatokból további mennyiségeket kell számolni. Ehhez 
adjunk egy új oszlopot a már meglév�khöz: válasszuk ki a Column > Add New Columns 
menüpontot és adjuk meg az új oszlopok számát. Az új oszlop tetejére kattintva kijelöljük az 
egész oszlopot. Ekkor kiválaszthatjuk a Data > Set Column Values menüpontot. A megjelen� 
párbeszédablakba írhatjuk be a kifejezést, amit ki szeretnénk számolni, illetve azt hogy ezt 
mely sorokra szeretnénk megtenni. Az adott oszlopra a col(oszlop neve) kifejezéssel 
hivatkozhatunk. Lehet�ség van adott sorra is hivatkozni a col(oszlop neve)[sor száma] 
kifejezéssel. (A col(név) egyenérték� a col(név)[i]-vel, minden sorban az aktuálisra 
hivatkozik). A képlet beírása után nyomjuk meg a Do it gombot. 
 
Statisztika 

Ha több adat átlagát szeretnénk kiszámolni, vagy statisztikai adatokra van szükségünk, 
akkor jelöljük ki az oszlopo(ka)t, válasszuk ki a Data menüpont Statistics on Columns pontját. 
A program egy újabb worksheet-be beírja az oszlop nevét (col(..)), a benne lév� adatok átlagát 
(Mean), szórását (sd), a szórás / n értéket (se), az adatok összegét (Sum) és számát (N). 
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Formázás 
 A Worksheet bármelyik üres területén kett�t kattintva megjelenik a Worksheet Display 
Control ablak, amelyben lehet�ségünk van ablakunk kinézetének átformálására. A szöveg, a 
háttér, a vonalak színezése, méretezése esztétikailag szebbé teheti adatlapunkat, de a 
jegyz�könyv szempontjából lényegtelen. Lényeges lehet azonban, hogy a táblázatnak címet 
adjunk, illetve hogy oszlopainak semmitmondó nevei (A, B, …) mellett a bennük lév� 
adatokra utaló címkét is megjelenítsünk (Column Label). A címadáshoz egy kis helyre van 
szükség az oszlopok felett: írjunk a Worksheet Elements részben a Gap from Top mez�jébe 
20-at. A címet a párbeszédablakból kilépve egy szöveges mez�be (Text Box-ba) [3] írjuk be. 
Az oszlopok címkéjének megjelenítéséhez ikszeljük be a Worksheet Display Control ablak 
Heading részének Column Label mez�jét és növeljük meg a Worksheet Elements részben a 
Column Heading Height mez�ben lév� számot a duplájára (szükség esetén még nagyobbra, 
hogy látsszon a címke). A címkét a Worksheet Column Format párbeszédablakban 
(kattintsunk kett�t az adott oszlop tetején) a Column Label mez�be írjuk be. Ugyanezen 
ablakban tudjuk beállítani az oszlop típusát (ha számolni szeretnénk a benne lév� adatokkal, 
vagy illeszteni rájuk, akkor numeric legyen!), Options részében a Format mez�ben a kiírás 
formátumát (pl. Decimal: 1000, Scientific: 1E3), a Decimal places mez�ben a kiírt tizedesek 
számát. 
 
M�VELETEK ÁBRÁKKAL 
 
Ábrák készítése 

Miután mindent kiszámoltunk, amire szükségünk van, hozzáláthatunk az ábrák 
elkészítéséhez. Kattintsunk annak az oszlopnak a tetejére, aminek függvényében akarjuk 
adatainkat ábrázolni, majd válasszuk ki a Column > Set as X menüpontot. Azután jelöljük ki 
az(oka)t az oszlopo(ka)t, ami(ke)t ezen X függvényében akarunk ábrázolni és a Column > Set 
as Y menü pontot válasszuk. Jelöljük ki ismét az egyik ábrázolni kívánt Y adatsort, majd 
válasszuk ki a megfelel� ábrázolási módot a Plot menü alól (Line = vonalként, Scatter = 
pontonként, Line+symbol = pontonként, de azokat vonallal összeköti)! Most a kapott 
grafikont láthatjuk. Nagyítsuk ki teljes képerny�sre. Az ablak bal fels� sarkában találunk egy 
kis 1-est. Erre kett�t kattintva beállíthatjuk, hogy a lapon mekkora legyen az ábra (Frame), 
illetve itt tehetjük rá azokat az adatsorokat, amiket még ugyanazon a grafikonon szeretnénk 
ábrázolni: az Available data alatti mez�b�l választhatunk oszlopot és a Layer contents felé 
mutató nyíl megnyomásával tehetjük fel a grafikonra. Itt természetesen le is vehetünk 
adatsorokat a grafikonról. A jobb alsó sarokban van egy Auto rescale on OK felirat. Ha az 
el�tte lév� kis négyzet be van jelölve, akkor automatikusan átskálázza a grafikont (úgy, hogy 
minden pont beleférjen), ha innen kilépünk az OK gomb megnyomásával. (Az átskálázást a 
Plot > Rescale to Show All menüponttal szükség esetén bármikor elvégezhetjük.) Az Origin a 
többedik adatsort általában vonalként teszi fel. Ha kett�t kattintunk a vonalra, akkor egy kis 
ablak tárul elénk. Itt megváltoztathatjuk az ábra típusát (Plot Type) az adott adatsorra nézve 
(pl: Line Graph, Scatter Graph), a vonal vagy jel színét (Line-Symbol Color). A Line feliratú 
kisablakban a Connect mellett az összekötés módját (pl. Straight, Spline), a Type mellett hogy 
a vonal folytonos, szaggatott vagy pontozott legyen, a Width mellett pedig a vonal 
szélességét. A Symbol feliratú kisablakban a Shape mellett a pont alakját adhatjuk meg, a 
Style mellett azt, hogy üres legyen, vagy ne, legyen-e pont a közepén stb., a Size pedig a 
mérete (javasolt méret 4-es, 5-ös).  Az ábrán azt is fel kell tüntetni, hogy mi van az egyes 
tengelyeken. Ezt az X ill. Y axis title feliratra való kett�s kattintással tehetjük meg [3]. Fontos 
még a megfelel� skálázás beállítása. Ezt a tengelyekre való kett�s kattintás után megjelen� 
párbeszédablakban lehet elvégezni. Beállíthatjuk, hogy mett�l, meddig, milyen lépésközzel 
skálázzon, a nagy osztások közé mennyi kicsit tegyen (Minor Ticks). Beállíthatjuk a tengely 
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típusát (pl. lineáris, logaritmikus) továbbá azt, hogy a tengelyek és tengelyfeliratok hol 
legyenek (alul-felül, jobb vagy bal oldalt, bent vagy kint). Szép a grafikon, ha keretes, azaz 
fönt és jobb oldalt be van húzva egy-egy, a tengelyekkel párhuzamos egyenes. Ezt az 
Additional Lines felirat alatti Opposite mez� bejelölésével érhet� el a legegyszer�bben. Végül 
készítsük el az ábrához a jelmagyarázatot [8]! 
 
Függvények illesztése 

Az ábrázolt pontokra nagyon gyakran kell egyenest (vagy más függvényt) illeszteni. 
Ha szeretnénk kiválasztani az illesztési tartományt (alapértelmezésben minden pontra illeszt), 
akkor nyomjuk meg a Toolbox-ban [2] lév�, egymással szembefordított le és fel nyilak 
gombját. Ekkor ugyanilyen jel jelenik meg az adatsor elején és végén. Ezek húzogatásával 
állíthatjuk be az illesztés els� illetve utolsó pontját. Ha ennek beállításával végeztünk, 
nyomjuk meg a nyilat a Toolbox-on vagy üssünk ENTER-t. A Fit menü megfelel� pontjának 
kiválasztásával indíthatjuk az illesztést. Egyenest a Linear Regression ponttal vagy Polinomial 
Regression.. ponttal illeszthetünk. (Célszer� ez utóbbit használni egyenes illesztésekor is, 
mert itt megadható az illesztett egyenes ábrázolásának kezdeti és végpontja (NEM az 
illesztési tartomány!), valamint az eredményt megfelel� számú értékes jegyre írja ki a 
program.) Az eredmény a Script Window-ban jelenik meg. [7] Lehet�ségünk van a program 
kiírásának módosítására vagy File(Text) menüben az eredmény elmentésére. 

Egy grafikonon több görbe illesztésér�l kés�bb olvashatunk [5]. 
Id�nként olyan függvényekkel kell illeszteni, amelyek nincsenek az eredeti Origin 

függvények között. Ekkor új függvényt kell definiálnunk. Válasszuk ki a Fit > 
Select Fitting Function.. menüpontot! Nyomjuk meg a Define New Function gombot! 
Értelemszer�en adjunk nevet a függvénynek, adjuk meg a paraméterek számát (saját neveket 
is használhatunk). Legegyszer�bben kifejezésként (Expression) (pl. 2*x+3) adhatjuk meg az 
illesztend� függvényt. Ezt írjuk be az alsó üres mez�be, majd nyomjuk meg az OK gombot. 
Válasszuk ki a Fit > Start Fitting Session.. menüpontot! Adjunk kezdeti értékeket a 
paramétereknek és kezdjük el az illesztést a fels� menüsorban lév� Fit lenyomásával. Amikor 
az illesztett függvényt elég jónak találjuk (a paraméterek konvergáltak), rajzoltassuk ki a 
Create Now gombbal, az illesztési eredményeket pedig írassuk közvetlenül a grafikonunkra a 
Plot gomb lenyomásával. 

 
Ha jól megnézzük, észrevehetjük, hogy a menüsor és a Toolbox más a Worksheet és a 

Plot ablak esetén. Ennek az az oka, hogy az Origin csak azokat a menüpontokat jeleníti meg, 
engedi kiválasztani, amelyek az adott esetben értelmes funkcióval bírnak (pl. Worksheet-nél 
nincs Fit menüpont, hiányzik néhány ikon a Toolbox-ból). 
 
TIPPEK ÉS TRÜKKÖK:  
1. Ha egy adatfile nem közvetlenül a beolvasandó adatokkal, hanem egyebeket tartalmazó 

sorokkal (pl. a mérésre vonatkozó adatok, leírás) kezd�dik, akkor ezt a header-t ki tudjuk 
hagyni: válasszuk ki a File > Import > Options…menüpontot, így az ASCII Import 
Options ablakhoz jutunk. Állítsuk a File Header részben a Skip main header of … lines 
mez�t a szükséges értékre és kezdjük meg a beolvasást az Import Now.. gomb 
lenyomásával. Ugyanitt a File Structure részben tudjuk beállítani, hogy milyen 
szerkezetb�l olvassa be a program az adatokat (elválasztó karakter van-e (ha van mi az), 
fix szélesek-e az oszlopok (ha igen mekkorák)). 

2. Ha a Tools ablak nem látható, akkor a Window menü alatti Toolbox bejelölésével el� lehet 
csalogatni. Ha a Toolbox hiányos (például a két, egymással szembe fordított nyilat 
ábrázoló ikont nem tartalmazza) és grafikon az aktív ablak, akkor t�ntessük el a Toolbox-
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ot, állítsuk vissza El�z� méret-re a grafikon ablakát, majd jelenítsük meg újra a Toolbox-
ot, végül nagyítsuk ki a grafikon ablakát újra Teljes méret-re. 

3. Szöveges mez� (Text Box) létrehozásához kattintsunk a Tools (To…) ablakban található T 
bet�re, majd a szöveg kívánt helyére. A megjelen� párbeszédablakban be lehet állítani a 
színt, a bet�típust, a szöveget. A szöveg formázásához segítséget nyújtanak a fölötte 
található gombok is. +: fels� index, -: alsó index, Greek: görög bet�k, (a többi gomb 
olyan, mint a word-ben).  

4. Vannak, akik szeretik, ha több ábrát tudnak egy oldalra tenni. Ezt meg lehet Origin-en 
belül is oldani úgy, hogy létrehozunk egy új Plot Window-t, letöröljük róla a tengelyeket, 
aztán a Copy Page és Paste segítségével megfelel� helyre másoljuk és kinagyítjuk az egy 
lapra teend� ábrákat. Ilyenkor figyeljünk arra, hogy illesztett görbe ne lógjon át a másik 
ábra térfelére. Ezzel a módszerrel Word-be is átmásolhatjuk az ábráinkat! A másik 
lehet�ség az, hogy az ábrát a File > Export page kiválasztásával Windows Metafile 
formátumúvá alakítjuk (WMF), majd Word-be képként beillesztjük. Ha utólag még 
valamit javítunk, akkor azt a régi változat helyére mindkét esetben újra át kell másolni / be 
kell illeszteni! 

5. Ha egy grafikonon két illesztett görbére van szükségünk, akkor kattintsunk kett�t az 
els� görbén rögtön az illesztés után, majd a megjelen� ablakban nyomjuk meg a 
worksheet gombot. Így az illesztett görbe pontjait tartalmazó worksheethez jutunk. 
Nevezzük át (Window > Rename), s utána illesszük az adatsorra a második görbét. 

6. Kés�bbi tanulmányaink során szükség lehet arra is, hogy több adatsort nagyon hasonló 
ábrán (pl. ugyanolyan feliratú, tengelybeosztású, ugyanolyan jelölés�) szeretnénk 
ábrázolni. Ehhez készítsük el az els� ábrát, majd a File > Template > Save as…menüpont 
kiválasztásával mentsük el! A következ�nél ugyanitt (File > Template > Open Plot 
Window…) megnyitjuk a kész ablakot és már csak az adatsort kell rátenni (és szükség 
esetén át kell skálázni). 

7. A Script Window-ban megjelent illesztési eredményt átmásolhatjuk a grafikonra egy 
szöveges mez�be: kijelöljük az érdekes részt, copy-zunk, átmegyünk a plot ablakra, 
létrehozunk egy szöveges mez�t (T a Toolbox-ban) és SHIFT-INSERT vagy CTRL-V 
lenyomásával beillesztjük az eredményeket.  

8. A program minden ábrázolásnál készít egy jelmagyarázatot (az ábrán található egy 
bekeretezett téglalapocska, amiben az ábrán látható adatsoroknak megfelel� pont ill. 
vonaltípusok valamint mellettük az oszlop nevei vannak feltüntetve). A keretre egyet 
kattintva azt kijelölhetjük. Ekkor a DEL billenty�vel törölhetjük a jelmagyarázatot. Ha 
kett�t kattintunk rá, akkor az el�t�n� kis ablakocskában megváltoztathatjuk a 
jelmagyarázatot (a %(i) hivatkozik az i. oszlop nevére). Új jelmagyarázatot a Plot > New 
Legend menüponttal készíthetünk (vigyázat, az addigi változtatásaink elvesznek!). 

 


